Stuck on three quests

I need help on three quests, thanks in advance:
1. Sunken cave. I’m looking for the coat of arms in the cave. I’ve hit all the switches and buttons, but there is a black wall that I can’t remove with what looks like a lever behind it. How do I get rid of it I’ve tried hitting it, trapping it, and using iron fist.
2. Royal Stag: I have gotten into the deer park, but can’t find the stag. I just see two witches, a pot, and a well full of frogs. How do I find the stag?
3. Stone folio: I’ve finished the storm folio quest, but dont have a dialogue option when I talk to Lord Sheets again. How do I get rid of the quest?

Thanks much and love the games.


  • edited November 2018

    You get the Coat of Arms in the Sunken Isle. You get there from the Sunken Lake. So I think you're in the Sunken Lake and I think I see that switch. To remove that wall, you have to step on a floor switch in the mid west.

    You won't find the Royal Stag unless you do a quest for the witches.

    Lord Sheets clears that quest. But you first have to have solved the quest to Save Caerworn Castle and you need the Stone Folio in your inventory when you talk to him. To save Caerworn Castle you have to do all the things the Stone Folio told you to do.

  • Got it. Thanks.

  • To remove the black wall, stand there and just face backwards and click the switch on the wall behind you
  • edited April 2020

    Where is the entrance to reach the sunken lake ?

  • I think I found it, in youtun's ridge after fixing the broken mirror

Sign In or Register to comment.