Kamber's Stronghold

I'm having a problem in Kamber's Stronghold. I finished it once and chose to side with Queen Habren, and everything was fine. Then I loaded an earlier save because I wanted to try to defeat Merlin. I got Merlin's Amulet from Mymbyr and went to the stronghold, knocked out the general and killed the guards, but now I can't open the door to go further in. It keeps saying "You can't see any method of opening this door". Am I missing something?

Also, when I finished the quest the first time, I was disappointed that there was no epilogue. Is there something else I have to do to see one or is there no epilogue for this expansion?


  • Uggghhh. Nevermind. I found the other door. I could have sworn I tried that before and it didn't work lol.

  • @Magtherion said:
    Uggghhh. Nevermind. I found the other door. I could have sworn I tried that before and it didn't work lol.

    Hi all, I am stuck on this door as well. Unable to open the door and unable to find the second door @Magtherion suggests. Any help is appreciated. This is my last quest for this expansion.

    Love the game and the expansions. Keep it up Cat!

  • edited January 8

    Thanks, Dritz. : ) You will only see one door, which is actually a gate, depending on whether you have Merlin's Amulet or Habren's Amulet. When you enter, you see two gray stone walls. If you have Merlin's Amulet, you can hit the northern gray stone wall and it reveals a gate (door). If you have that amulet in your inventory and tap that gate, it will open. You can't open the southern gray stone wall at all.

    If you have Kamber's Amulet in your inventory, you can only tap and open the southern gray stone wall and tap and open the gate (door) there. You can't open the northern wall or gate (door).

  • Thank you Cat!

  • Of course, I have either sold Kamber’s amulet or “lost” it. It’s not sold by Phredd either. Sleeper the 21 times and went back through Kamber’s castle. Any other suggestions on how to reaquire Kamber’s amulet?

    Thanks again for the great game.

    Level 55 Nogur

  • The amulets can't be sold. You had to have it to open the wall before the gate. Maybe you stashed it somewhere? Otherwise, you'd have to go back to a previous save file. The reason Phredd doesn't sell the amulets is then it would be possible to kill both Merlin and Kamber and that's not intended.

Sign In or Register to comment.